inkscapeforum.it

Inkscape Generale => Inkscape Varie => Topic aperto da: davidebe - 12 Aprile, 2019, 21:42:49 pm

Titolo: oggetto pixellato con copia e incolla
Inserito da: davidebe - 12 Aprile, 2019, 21:42:49 pm
Ciao a tutti,

ho un file svg come in allegato che voglio replicare.
Aprendo un nuovo file con inkscape e copiando e
incollando la lettera 'alpha' dal file in allegato sul nuovo file,
questa mi risulta pixellata e non vettoriale.
Sapete come fare per mantenerla vettoriale?

grazie
Davide.
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: bobol - 12 Aprile, 2019, 22:03:36 pm
Apri il file direttamente da inkscape senza copincollare.
PS
appena rientrato ho fatto la prova ed in effetti non succede, l'oggetto "alfa" (tracciato di 18 nodi) rimane un tracciato copiandolo ed incollandolo in un nuovo documento , e come indicato da undernature nel post seguente, la cosa è alquanto strana.
Dunque alcune domande:
- Succede solo con questo elemento e con questo file o comunque indipendentemente dall'oggetto vettoriale che copi da un qualsiasi documento?
- All'interno dello stesso documento il "copiaincolla" funziona bene?
- Una volta incollato l'oggetto nel nuovo documento, quando lo selezioni cosa leggi nella descrizione in basso sotto l'area di lavoro?
- Ed un'ultima cosa che potrebbe anche essere irrilevante, che SO e che versione di Inkscape stai utilizzando?
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: undernature - 12 Aprile, 2019, 23:44:56 pm
In effetti è strano, perché dovrebbe incollarti un file vettoriale, sei sempre dentro Inkscape, è un'operazione che ho fatto svariate volte non ho mai avuto di questi problemi.
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: davidebe - 15 Aprile, 2019, 16:09:55 pm
Ciao Bobol,
rispondo alle tue domande.
- il fenomeno succede indipendentemente dall'oggetto vettoriale che copio da un qualsiasi elemento.
- all'interno dello stesso documento il copia/incolla genera oggetti bitmap, solo se scelgo Duplica l'oggetto rimane vettoriale.
- Immagine 13 x 13: integrato in livello Livello 1.
- Mac OSX 10.11 e Inkscape 0.91
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: undernature - 15 Aprile, 2019, 16:27:28 pm
Questo problema ce l'hanno solo gli utenti con Mac OS X, è un problema di XQuartz, rimando alle FAQ di Inkscape in merito a questo argomento:

http://wiki.inkscape.org/wiki/index.php/Frequently_asked_questions#Copying_and_pasting_in_Inkscape_creates_pixellated_images_instead_of_copying_the_vector_objects
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: bobol - 15 Aprile, 2019, 20:27:32 pm
bene, grazie alla ricerca di @undernature abbiamo circoscritto il problema al SO.
Per ovviare al problema consigliano di disattivare la funzione in X11 preferences > Pasteboard: uncheck "Update Pasteboard when CLIPBOARD changes"
Tuttavia, ciò impedirà anche di copiare il testo da qualsiasi applicazione X11 a quella di Mac OS X. Non impedirà la copia del testo da OS X a X11
Sempre se non ho "tradotto male"  wink
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: davidebe - 15 Aprile, 2019, 21:42:24 pm
Ok,
grazie al vostro aiuto ho risolto il problema.

Mille grazie Bobol e undernature.
Titolo: Re:oggetto pixellato con copia e incolla
Inserito da: undernature - 15 Aprile, 2019, 23:46:04 pm
Ciao davidebe, visto che hai risolto il problema penso sia meglio aggiungere "Risolto" al titolo del post, almeno chi ha lo stesso problema sa che è risolvibile.

Grazie!!!
byeee